What Are The Minimum System Requirements For The NBP Plugins?

PRO_Banner_1500.png

OVERVIEW

The NBP Plugins have some minimum system requirements in order to function properly.

 

Shortcuts: Jump straight to what you're looking for.

 

NBP Plugins 

What Are The Minimum System Requirements For The NBP Plugins?

Below are listed the minimum system requirements for the NBP Plugins to work on a computer system. 

 

Hardware:

  • CPU: Intel CPU with SSE 4 Support (Most CPU’s from 2007 and above) or AMD Ryzen.
  • RAM - 4 GB of RAM (8 GB is recommended) or above.

Operating System:

  • Windows (64 Bit Version)
    Windows 7 / Windows 8 / Windows 8.1 / Windows 10.
  • macOS
    macOS 10.7 and above.
  • Adobe Photoshop 64 Bit Version
    Photoshop CC 2015.5 through current.

Email support@proedu.com with any questions. 

Articles in this section

Was this article helpful?
0 out of 1 found this helpful
Share

Comments

0 comments

Article is closed for comments.